After Updating AMI, Nothing Works


#1

I have a community version running on an EC2 instance, via AMI. I ssh’d onto the instance and executed the following commands:

sudo systemctl stop mapd_web_server
sudo systemctl stop mapd_server
sudo yum install mapd

Downloading packages:
Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
mapd-ce-4.1.1-20180904-24da2a8d2d-Linux-x86_64-render.rpm  | 176 MB   00:24     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Updating   : mapd-4.1.1_20180904_24da2a8d2d-1.x86_64                      1/2 
  Cleanup    : mapd-3.3.1_20171108_32e7bcc-1.x86_64                         2/2 
  Verifying  : mapd-4.1.1_20180904_24da2a8d2d-1.x86_64                      1/2 
  Verifying  : mapd-3.3.1_20171108_32e7bcc-1.x86_64                         2/2 

Updated:
  mapd.x86_64 0:4.1.1_20180904_24da2a8d2d-1                                     

Complete!

Then:

sudo systemctl start mapd_server
sudo systemctl start mapd_web_server

However, now when I login, it fails to run any dashboards, find any data, or run any SQL queries. Help?


#2

Hi @mayanklive1,

That’s a relatively old version of MapD, it would be best to launch a new instance of the latest AMI from the AWS Marketplace.

Regards,
Veda


#3

Hi Veda,

Understood, but we had all of our dashboards pre-created on that instance. Those teams were not counting on losing them. Is there a fix, or do we have to start over?


#4

Hi @mayanklive1,

In case you want to preserve the data then best to upgrade the CUDA drivers and see if you are able to restart MapD. You can export the dashboards to a JSON file for importing it to another MapD instance.

Regards,
Veda