Compiler error with folly : gflags invalid


#1

I download folly-2017.04.10.00.zip , but some wrong with folly
[root@localhost folly]# ./configure --prefix=/usr/local/mapd-deps
then "checking for main in -lgflags… yes

checking for gflags viability… no

configure: error: “gflags invalid, see config.log for details”

I am make gflags as compiler: /usr/local/lib/libgflags.a , is a static lib
vi config.log , said:

/usr/local/lib/libgflags.a(gflags.cc.o): In function `google::(anonymous namespace)::FlagRegistry::GlobalRegistry()’:

gflags.cc:(.text+0xe96): undefined reference to `pthread_rwlock_wrlock’

gflags.cc:(.text+0xeae): undefined reference to `pthread_rwlock_unlock’

gflags.cc:(.text+0xf47): undefined reference to `pthread_rwlock_init’


#2

my OS is CENTOS 7
my OS is CENTOS 7


#3

Hi

thanks for working with the MapD database

Please follow these instructions here for centos 7

We have a set of prebuild dependencies which should work for you and save you building them yourself.

Regards