Copy command delimiter support only single Character


#1

Hi ,

We are checking the copy command to load file. These files are using ‘|-|’ as a field separator.

Checked and observed that MapD support single character string as delimeter.
delimiter: A single-character string for the delimiter between input fields. Default: “,” (a CSV file)

Now a days it is very difficult to use single character as delimiter. As chances are high this value will use anywhere in text field.

Please let us know is it any way possible to use combination of 2-3 character to use as delimiter.

Regards,
Sumit


#2

@sumit you are finding new and impressive ways to test our limits! Unfortunately, at this time we do not support custom delimiters. Is it possible to pre-process your data to replace those multi-character delimiters?


#3

My suggestion is to use pipe as quote character and the minus as field delimiter; you need to pre-process files to add the pipe at the start and the end of the rows

Reference to options of copy command
http://docs.mapd.com/latest/6_loading_data.html

Hopes this helps


#4

@aznable

thanks and this logic works will work for me.

Regards,
sumit


#5

thanks it is working as expected way