Docker Installation issue


#1

I installed Docker and I am attempting to install MapD using the CPU only instructions. When I paste the command into the command prompt, the application downloads, however I get this error “Error response from daemon: create $HOME/mapd-docker-storage: “$HOME/mapd-docker-storage” includes invalid characters for a local volume name, only “[a-zA-Z0-9][a-zA-Z0-9_.-]” are allowed. If you intended to pass a host directory, use absolute path.” Do I need to change the installation command? I am using Windows 10 Pro


#2

Sorry, the docs weren’t clear that they assume Linux/macOS. Docker on Windows works, but can be a little problematic when dealing with volumes.

In your case, instead of specifying $HOME/mapd-docker-storage, try specifying an absolute path such as c:/mapd-docker-storage. You can try using something in your home directory (c:/Users/username), though you might have issues if there are spaces in your username.

Also, you need to mark your drive as “Shared” in Docker before you can share it with a container. In the Docker Settings, select Shared Drives and check the box next to the drive you want to use.