Exception: Query would require a scan without a limit on table(s):


#1

Hi,

We have installed the community edition. When we run :

select * from cust_performance

we get the error message: Exception: Query would require a scan without a limit on table(s).

When we put a limit it works upto the some point . However after passing a point we get the error message:

select * from cus_performance_V3 limit 10000000
Exception: Query couldn’t keep the entire working set of columns in GPU memory

Does Mapd not work in cpu memory(RAM)? We thought that mapd keeps data in memory and put data in gpu memory if need be.
Do we get this error messages because we use the community edition? Moreover, we have 2 Gpus whose memory amounts to 32GB but when we checked the nvidia-smi command the gpu memory usage does not exceed 3GB on each gpu. What is the reason for this?


#2

You should be able to simply set enable-watchdog = false in your mapd.conf file or as a parameter to starting mapd_server and have the query execute step wise on GPU.

Then restart MapD to pick up the change.

This has been answered in a few posts already.
here

also here


#3

Hi,

The error message here is misleading.

This query is not using ANY gpu memory at all.

Currently MapD does not do any “paged” style access to results. It materializes the entire result set and then send it to the client.

MapD is targeting an analytic use case., where you want to slice and dice large datsets down into more managable resultsets (or just aggregated results). Using a Analytic Column Store to do a large SELECT * query is not normally a good combination.

What is your use case where you need to dump an entire table with a SELECT * how do you intend to process your 10M plus output records?

regards