Kill query in SQL editor


#1

Hello,

One of my queries in the SQL editor is taking hours to process (a join on large tables followed by a count) - blocking the possibility to run other queries.

Is there a possibility to “kill” the query?

So far my only solution was to stop mapd_server and start it again.

Thanks,


#2

@gofs I don’t have a direct answer for you, but are you enabling the watchdog utlity? This should help determine if your query can execute in a reasonable amount of time.

What can you share with us about the query and the dataset?


#3

Hello,

Sorry for the late delay

I can’t remember what was the query, but it was something too complicated (join between tables with 100millions of rows). I entered the query too fast, then realised it would take ages and wanted to cancel.

The issue was that with the UI, there is no way to kill the query and no way to start the next one.

For enable-watchdog, is it disabled by default (the documentation seem to suggest it is enabled by default). I couldn’t see it, but again in that configuration I was only using the UI (MapD Immerse)


#4

infact the watchdog would be enabled by default

./mapd_server --help-advanced
[cut]
  **--enable-watchdog [=arg(=1)] (=1)     Enable watchdog**
  --enable-dynamic-watchdog [=arg(=1)] (=0)
                                        Enable dynamic watchdog
  --dynamic-watchdog-time-limit [=arg(=10000)] (=10000)
                                        Dynamic watchdog time limit, in
                                        milliseconds
[cut]

to disable you have to override the default in mapd.conf