MapD GPU-backed segfault when trying to import data


#1

Hi there,

I am running a GPU-backed version of MapD 3.6 Enterprise version. I’ve used the provided Dockerfile to create a docker image. Using that docker image, whenever we try to feed it a file to start an import, it would segfault and restarts. I have the coredump as well as strace output here

# strace /mapd/startmapd --non-interactive --data /mapd-storage/data --config /mapd-storage/mapd.conf
[{WIFSIGNALED(s) && WTERMSIG(s) == SIGSEGV && WCOREDUMP(s)}], 0, NULL) = 83
rt_sigaction(SIGINT, {0x45c8f0, [], SA_RESTORER, 0x7f01694244b0}, {0x4449b0, [], SA_RESTORER, 0x7f01694244b0}, 8) = 0
write(2, "/mapd/startmapd: line 110:    83"..., 199/mapd/startmapd: line 110:    83 Segmentation fault      (core dumped) ./bin/mapd_server $MAPD_DATA $RO --port $MAPD_TCP_PORT --http-port $MAPD_HTTP_PORT --calcite-port $MAPD_CALCITE_PORT $CONFIG $*
) = 199
rt_sigprocmask(SIG_BLOCK, [CHLD], [CHLD], 8) = 0
rt_sigprocmask(SIG_SETMASK, [CHLD], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [CHLD], 8) = 0
rt_sigprocmask(SIG_SETMASK, [CHLD], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [CHLD], 8) = 0
rt_sigprocmask(SIG_SETMASK, [CHLD], NULL, 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
--- SIGCHLD {si_signo=SIGCHLD, si_code=CLD_KILLED, si_pid=83, si_uid=0, si_status=SIGSEGV, si_utime=32, si_stime=677} ---
wait4(-1, 0x7fff1a5f8e90, WNOHANG, NULL) = 0
rt_sigreturn({mask=[]})                 = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, NULL, [], 8)  = 0
rt_sigaction(SIGTERM, {SIG_DFL, [], SA_RESTORER, 0x7f01694244b0}, {0x45c8f0, [], SA_RESTORER, 0x7f01694244b0}, 8) = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
kill(4294967216, SIGTERM)               = -1 ESRCH (No such process)
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
write(2, "/mapd/startmapd: line 1: kill: ("..., 55/mapd/startmapd: line 1: kill: (-80) - No such process
) = 55
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
exit_group(1)                           = ?
+++ exited with 1 +++

Not sure how to get the coredump to you, but in any case, where do I go from here?

Thank you,


#2

Hello @mayppong. Someone will be along shortly to help out, although since it’s the weekend, it may not be tonight.


#3

Hi @mayppong, since you’re using Enterprise Edition you can email support@mapd.com. We’ll figure out the details of getting that coredump, and any other applicable info to sort this out.

Thanks!
Mike