MapDHandler. Exception: OutOfMemory


#1

Has anyone any idea why I got this error?


#2

@achim can you provide any more information about:

  • your hardware and environment / deployment architecture (example: Community Edition installed locally on a single GPU)
  • what version of MapD you are using (example: 4.0)
  • at what point you encounter this error?

If this error is occuring while running a query, it would also help to know:

  • information about your data (such as size, number of rows / columns, schema, sample data if possible)
  • information about your query (such as the query itself, obfuscated if you prefer)

Since you posted in the topic of Immerse, I’m going to assume that’s where it’s happening. Please correct me if I’m wrong about that assumption.


#3

Hello,

I am experiencing same problem as stated in the post title in Immerse.
image

My env is as following:

  • Community Edition installed on host with 4 GPU - NVIDIA GV100GL Tesla V100 SXM2
  • Version 4.0.0
  • Immerse Point Map (with 15 decimal places lat,lon or point delivered in the chart config)

The data is NYC Taxi data but the error occuring even when I have a sample table of 10 records only …

Would know the reason for having this issue now?


#4

I may add that current memory usage is also as following:
image

Regards,
Mateusz.


#5

@easy
Hi Eric,
Was this problem previously investigated or resolved here or somewhere, or should I maybe open it in a new topic regarding ‘OutOfGpuMemoryError’ for anyone’s attention?
Thank you,


#6

I would recommend trying setting --render-mem-byes=2000000000, either as a server startup flag or in the mapd.conf file. See here for more details.

Let us know if this works!


#7

Hi @darwin,
Sorry for this question but what is the correct manner of setting the parameters on the server startup?
I try:
sudo systemctl start mapd_server – render-mem-bytes=2000000000
and it fails - “Failed to start render-mem-bytes\x3d2000000000.service: Unit not found.”
I didn’t find any console examples in the documentation.
My OS is Ubuntu


#8

you have to modify the mapd.conf file if you want to start as a service.

if you are using default directories it would be located on `/var/lib/mapd

just add the line to the first section of configuration file

port = 9091
http-port = 9090
data = "/opt/mapd_storage/data"
null-div-by-zero = true
render-mem-bytes = 1519430400

#9

@darwin
This helped. I can now render this 1 billion taxi dataset on the map. Thank you!
@aznable
Thank you very much also for pointing me to the right direction with the configuration file :slight_smile: