Migrating Dashboards


#1

Hello,

I’ve built some dashboards in the 3.1.1 version, and now I wish to move them into the new 3.1.2 version.

How could i do ?

They are pretty long to rebuild from scratch. In general it should be an upgrading process for the Immerse dashboards.

Thank in advance.


#2

Hi

Is there a reason you could.not update the v3.1.1 version.

The existing dashboards and db would just continue to work under 3.1.2.

If this is not possible I will supply you a utility to do the migration.

Regards


#3

I just don’t understand how they would keep working : I installed correctly MapD 3.1.2, imported the data of the dashboard into the database, opened Immerse , and I don’t see any of the old Dasboards.

What should I do in order to see them ?


#4

you have to install the new version with the same config file of the old one, so the software will point to same mapd_storage area


#5

Could I just copy the old mapd_storage over the new one keeping my new config files?


#6

Hi,

Yes if you stop the old map_server and then cp or mv the data across it will work fine.

regards


#7

Got it working, thank you Dwayne.