Node js MapD connector


#1

when I am using MapD connector 4.0.1, a weird problem comes out. It is like

Why comes out an error of ‘skip not support yet’?

Any help? Thanks in advance.


#2

Hi @bobofee -

The last time this came up, it was an issue with outdated Apache Thrift files:

Are you a GitHub user? If so, it’d be great if you can open a new issue at mapd-connector, referencing the issue I linked above. If not, I can open an issue. In the meantime, I’ll ping one of our internal JS folks to see if they can replicate the issue and figure out a fix.


#3

@randyzwitch Thanks for your kindly reply. I have read the thread. when I run the mapd example to connect metis.mapd.com, it works well. But when I connect my own mapd server, it does not work.


#4

Interesting. This suggests to me that your MapD server and the connector are targeting two different versions.

Do you know what version of MapD your server is running?


#5

mapdql> \version
MapD Server Version: 4.1.0dev-20180815-68dfa2893f