The collision of spring framework and mapd jdbc driver


#1

Hi.

I am using MapD(Release 3.2.0) database for the first time.

I’m trying to connect to the MapD database using MapD driver(mapdjdbc-1.0-SNAPSHOT-jar-with-dependencies.jar) in the Spring Framework, but the connection failed.

The MapD jar file and the spring framework log4j jar file are in conflict.
(log4j-api-2.1.jar, log4j-core-2.1.jar, log4j-over-slf4j-1.7.7.jar, log4j-slf4j-impl-2.1.jar)

Could you give me some advise in this problem?


#2

Hi,

Here is a experimental jdbc driver that includes no log4j. please give it a try and let us know if it works for you.

mapdjdbc-1.0-with-dependencies-no-log4j.jar.zip (2.4 MB)

It does still have the slf4j api

Any feedback appreciated

regards


#3

Hi,

On a side note I would recommend you upgrade from 3.2.0 that is quite old

regards


#4

Hi,

I used Thrift to connect to MapD from Spring Framework.

regards.