TSocket::open() connect() <Host: localhost Port: 9091>Connection refused


#1

Hi,

i am trying to install mapd on a physical box with 2 NVIDIA GPUs, unfortunately when it comes to download some samples to insert , it throws the error below:

flights_2008_10k/
flights_2008_10k/flights_2008_10k.csv
flights_2008_10k/flights_2008_10k.sql
/opt/mapd

  • adding schema

Thrift: Wed Nov 1 14:16:31 2017 TSocket::open() connect() <Host: localhost Port: 9091>Connection refused
Thrift: Wed Nov 1 14:16:31 2017 TSocket::open() connect() <Host: localhost Port: 9091>Connection refused
terminate called after throwing an instance of 'apache::thrift::transport::TTransportException’
what(): connect() failed: Connection refused
./insert_sample_data: line 94: 6589 Aborted (core dumped) ./bin/mapdql mapd -u mapd -p HyperInteractive --port “$MAPD_TCP_PORT” < “$SAMPLE_PATH/$filebase”/*.sql

Seems port 9092 is up and 9091 is down, could you pls advice how i can get this fixed? Thank you.

mapd: 3.3.0-20171026-ed76a7a
cuda: Driver Version: 384.66
OS: Ubuntu 16.04.3


#2

here somes some details in log:

Log line format: [IWEF]mmdd hh:mm:ss.uuuuuu threadid file:line] msg
I1101 14:15:54.791870 6372 MapDServer.cpp:606] MapD started with data directory at '/u1/mapd_data/data’
I1101 14:15:54.792076 6372 MapDServer.cpp:613] Watchdog is set to 1
I1101 14:15:54.792091 6372 MapDServer.cpp:635] cuda block size 0
I1101 14:15:54.792100 6372 MapDServer.cpp:636] cuda grid size 0
I1101 14:15:54.792109 6372 MapDServer.cpp:637] calcite JVM max memory 1024
I1101 14:15:54.792115 6372 MapDServer.cpp:638] MapD Server Port 9091
I1101 14:15:54.792124 6372 MapDServer.cpp:639] MapD Calcite Port 9093
I1101 14:15:54.792140 6372 MapDHandler.cpp:151] MapD Server 3.3.0-20171026-ed76a7a
I1101 14:15:58.607326 6372 CudaMgr.cpp:127] Using 2 Gpus.
I1101 14:15:58.607425 6372 DataMgr.cpp:120] cpuSlabSize is 4096M
I1101 14:15:58.607445 6372 DataMgr.cpp:122] reserved GPU memory is 604.837M includes render buffer allocation
I1101 14:15:58.607462 6372 DataMgr.cpp:132] gpuSlabSize is 2048M
I1101 14:15:58.607470 6372 DataMgr.cpp:132] gpuSlabSize is 2048M
I1101 14:15:58.607602 6372 FileMgr.cpp:173] Completed Reading table’s file metadata, Elasped time : 0ms Epoch: 0 files read: 0 table location: '/u1/mapd_data/data/mapd_data/table_0_0/'
I1101 14:15:58.607636 6372 Calcite.cpp:156] Creating Calcite Handler, Calcite Port is 9093 base data dir is /u1/mapd_data/data
I1101 14:15:58.607645 6372 Calcite.cpp:95] Running calcite server as a daemon
I1101 14:15:58.922842 6372 Calcite.cpp:124] Calcite server start took 300 ms
I1101 14:15:58.922883 6372 Calcite.cpp:125] ping took 12 ms

I1101 14:15:58.928692 6372 MapDHandler.cpp:196] Started in GPU mode
E1101 14:15:58.933307 6472 EglDisplayManager.cpp:116] EGL error trying to initialize display for device 0
I1101 14:15:58.933804 6472 QueryRenderManager.cpp:185] Render thread exited normally


#3

Hi

Could you let us know what the two GPU cards you are trying to run are. Are they identical?

Please run nvidia-smi from command line and share the output.

Michael.


#4

Hi Michael, here is the output.
a


#5

Hi,

It appears you have all the memory on the GPU’s allocated to a python process (pid 6731).

Shutdown that process and then try to restart MapD.

regards


#6

i have stopped the python process and tried to restart mapd, it still threw out the same error above, any more advice?

Much appreciated.

±----------------------------------------------------------------------------+
| NVIDIA-SMI 384.66 Driver Version: 384.66 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 Tesla K20Xm Off | 00000000:06:00.0 Off | 0 |
| N/A 48C P0 58W / 235W | 75MiB / 5699MiB | 0% Default |
±------------------------------±---------------------±---------------------+
| 1 Tesla K20Xm Off | 00000000:83:00.0 Off | 0 |
| N/A 39C P0 57W / 235W | 75MiB / 5699MiB | 0% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| 0 16815 C /opt/mapd/bin/mapd_server 64MiB |
| 1 16815 C /opt/mapd/bin/mapd_server 64MiB |
±----------------------------------------------------------------------------+

I1102 08:53:24.460928 16815 MapDHandler.cpp:196] Started in GPU mode
E1102 08:53:24.467962 16880 EglDisplayManager.cpp:116] EGL error trying to initialize display for device 0
I1102 08:53:24.468773 16880 QueryRenderManager.cpp:185] Render thread exited normally


#7

Could you try running the following and see if those errors still occur:

sudo nvidia-smi --gom=0

The K20 is a bit strange in that it requires you to explicitly enable graphics/rendering support. Not sure if that’s the issue here though.


#8

Hi,

Could we also confirm what EGL is linking in? run

ldd bin/mapd_server | grep EGL

from the mapd install directory

regards


#9

I run “sudo nvidia-smi --gom=0” and reboot the box. It’s working now!!!

Thank you Michael and Andrew!!!


#10

Hi,
Am trying to set up MapD CE with NVIDIA Geforce GT 610 GPU. When i import test data; the system runs into errors. Thrift: Fri Nov 3 16:36:36 2017 TSocket::open() connect() <Host: localhost Port: 9091>Connection refused. I can’t login from MapD Immerse as well, i get the error: Unable to connect to Hostname or Port.

Thanks.


#11

Hi Mark,

Unfortunately the GT 610 is a Fermi architecture GPU (compute capability 2.1), which is not supported. Kepler / CC 3.0 is the minimum required.

You can still run in CPU-only mode by passing the --cpu flag.

I’ll file an issue to improve the error message when using an unsupported GPU.

Andrew


#12

Hi Andrew,

Thank you for the info. I will look for a compatible GPU.

Regards