Uninstall / Remove MapD


#1

Hi,

I’m new to MapD. How to do a clean uninstall of MapD for Ubuntu 16.04 amd64?


#2

@sara_chan what was your method of installation?


#3

@easy I followed the instructions for MapD community edition GPU installation with Tarball.


#4

@sara_chan in that case:

  • stop the relevant systemd services
  • remove the relevant systemd services
  • delete the directory you created during installation

You have also inspired me to ask for this information to be added to the official documentation.


#5

For anyone else finding this thread, the above solution works for a simple tarball install.
If you used a package manager to install MapD, you should use the same package manager to uninstall.


#6

@easy I tried uninstall but it does not uninstall thrift. Here the steps that i took:

  • sudo systemctl stop mapd_server
  • sudo systemctl stop mapd_web_server
  • sudo systemctl disable mapd_server
  • sudo systemctl disable mapd_web_server
  • sudo rm –r $MAPD_STORAGE
  • sudo rm –r $MAPD_PATH

After that, i reinstalled mapd, according to the steps in https://www.mapd.com/docs/latest/4_ubuntu-tarball-gpu-ce-recipe.html#installation. However, i encountered these errors after executing ‘./install_mapd_systemd.sh’:

Thrift: Wed Sep 19 12:00:35 2018 TSocket::open() connect() <Host: localhost Port: 39093> Connection refused
Thrift: Wed Sep 19 12:00:35 2018 TSocket::open() connect() <Host: localhost Port: 39093> Connection refused
Thrift: Wed Sep 19 12:00:35 2018 TSocket::open() connect() <Host: localhost Port: 39093> Connection refused

Please advise.


#7

the weird thing is the software trying to connect to 39093 port; calcite server starts on 9093 port.


#8

I am the same with you…


#9

The 39093 messages you are seeing when running the start or install scripts are actually coming from the MapD data directory initiialization step (initdb). We import three geospatial files with every data directory initialization so that users have some geospatial data available for the Immerse choropleth chart (though there is a flag, —skip-geo, that will skip sample geo import if running initdb directly). We need to startup the calcite daemon when we’re creating the table / importing data, but we run it on a different port (39093) so it won’t conflict with any daemons already running.

Those error messages are just timeouts while we’re waiting for calcite to startup. It’s normal to see 1 or 2 messages like the above when starting mapd_server or using initdb.

Alex


Why my mapd server try to connect calcite server by port 39093